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When you create a form, you can design it in a way that works with your database and makes sense to you. In
this lesson, you will learn how to create and modify forms. Wewill be showing you how to create forms with
examples fromour sample bakery database. If you would like to follow along, download our example and use
it to follow the proceduresdemonstrated in this lesson. Creating forms Access makes it easy to create a form
from any table in your database. To create a form: In the Navigation pane, select the table you want to use to
create a form. You do not need to open the table. Select the Create tab on the Ribbon, and locate the Forms
group. Click the Form command. Using the Form command to create a form from the Customers table Your
form will be created and opened in Layout view. The new form To save the form, click the Save command on
the Quick Access toolbar. When prompted, type a name for the form, then click OK. Naming and saving the
form About subforms If you created a form from a table whose records are linked to another table, your form
probably includes a subform. A subform is a datasheet form that displays linked records in a table-like format.
For instance, the subform included in the Customers form we just created displays linked customer orders.
Simply click it and press the Delete key. Depending on the content and source of your form, you might find
that the subform contains useful information, as in the example below. In our Orders form, the subform
contains the name, quantity, and price of each item contained in that order, which is all useful information.
Our Orders form, which includes a useful subform Adding additional fields to a form When you use the Form
command on an existing table, all of the fields from that table are included in that form. However, if you later
add additional fields to that table, these fields will not automatically show up in existing forms. In situations
like this, you can add additional fields to a form. To add a field to a form: Click the Add Existing Fields
command. Select the field or fields to add to your form. If you want to add a field from the same table you
used to build the form, double-click the name of the desired field. Selecting a field from the source table To
add a field from a different table: Click Show All Tables. Double-click the desired field. Selecting a field from
another table The new field will be added. The added field You can also use the above procedure to add fields
to a totally blank form. Simply create a form by clicking the Blank Form command on the Create tab, then
follow the above steps to add the desired fields. The Blank Form command Adding design controls Design
controls set restrictions on the fields in your forms. This helps you better control how the data is entered into
your forms, which in turn helps keep your database consistent. Combo boxes A combo box is a drop-down list
you can use in your form in place of a field. Combo boxes limit the information users can enter by forcing
them to select only the options you have specified. Combo boxes are useful for fields that have a limited
number of possible valid responses. For instance, you might use a combo box to ensure people only enter a
valid U. To create a combo box: Select the Combo Box command, which looks like a drop-down list. The
Combo Box command Your cursor will turn into a tiny crosshairs and drop-down list icon. Move the cursor to
the place where you want to insert the combo box, then click. A yellow line will appear to indicate the location
where your combo box will be created. In our example, the combo box will be located between the City field
and the Add to Mailing List? Selecting the location of the new combo box The Combo Box Wizard dialog box
will appear. Select the second option, I will type in the values that I want, then click Next. The Combo Box
Wizard dialog box Type the choices you want to appear in your drop-down list. Each choice should be on its
own row. In our example, we are creating a combo box for the Add to Mailing List? Users will be able to
select one of three choices from our finished combo box: Once you are satisfied with your list, click Next.
Resizing the column that will appear in the combo box Select Store that value in this field, then click the
drop-down arrow and select the field where you want selections from your combo box to be recorded. After
making your selection, click Next. Selecting the field that will be affected by the combo boxâ€”choices made
while using the combo box will be recorded in this field Enter the label, or the name that will appear next to
your combo box. Naming the combo box Click Finish. Your combo box will appear on the form. If you
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created your combo box to replace an existing field, delete the first field. In our example, you might notice
that we now have two fields with the same name. Deleting the field which the combo box replaces Switch to
Form view to test your combo box. Simply click the drop-down arrow and verify that the list contains the
correct choices. The combo box can now be used to enter data. This will allow you to create a drop-down list
from a table field. A combo box that takes its values from a table Some users report that Access malfunctions
while working with forms. If you have a problem performing any of these tasks in Layout view, try switching
to Design view. Customizing form settings with the Property Sheet The Property Sheet is a pane containing
detailed information on your form and each of its components. From the Property Sheet, you can make
changes to every part of your form, both in terms of function and appearance. The best way to familiarize
yourself with the Property Sheet is to open it and select various options. When you select an option, Access
will display a brief description of that option on the bottom-left border of the program window. Watch the
video to learn how to use the Property Sheet to change form settings. Selecting a Property Sheet option to find
out what it does Pay close attention as you modify your form and its fields. Because there are so many options,
it can sometimes be challenging to remember which one you used to modify each aspect of your form.
Modifying form settings There are far too many options in the Property Sheet to discuss them all in detail.
Practicing these procedures should give you a sense of how to work with other Property Sheet settings as well.
To hide a field: In either Layout or Design view, select the Design tab and locate the Tools group. Click the
Property Sheet command. On the form, select the field you want to hide. Selecting the field we wish to hide.
Note that the Property Sheet is open in a pane on the right. In the Property Sheet, click the Format tab and
locate the Visible option on the third row. Click the drop-down arrow in the column to the right, then select
No. Selecting "No" from the drop-down list in the Visible option Switch to Form view to verify that the field
is hidden. To set a field to auto-fill with the current date: On the form, select the field you want to
automatically fill in the current date. This must be a field with the date data type. Selecting the date field In the
Property Sheet, click the Data tab and select the Default Value field in the fourth row. Click the Expression
Builder button that appears in the column to the right. In the Expression Elements list, click the words
Common Expressions. In the Expression Categories list, double-click Current Date. The Current Date
expression Switch to Form view to verify that the expression works. When you create a new record with that
form, the date field you modified will automatically fill in the current date. The current date is automatically
entered into the Pickup Date field when a new record is created Challenge! Create a form from the Customers
table. Add the following choices to the combo box:
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Create a new blank table. Create a new table using a table template. Create a list on a SharePoint site and a
table in the current database that links to the newly created list. Create a new blank table in Design view.
Create a new form based on the active table or query. Create a new pivot table or chart. Create a new report
based on the active table or query. Create a new query, macro, module, or class module. External Data Import
or Link to external data. Collect and update data via e-mail. Create saved imports and saved exports. Run the
Linked Table Manager. Database Tools Move some or all parts of a database to a new or existing SharePoint
site. Launch the Visual Basic editor or run a macro. Create and view table relationships. Run the Database
Documenter or analyze performance. Click the control that represents the command. Alternatively, if you
know the keyboard shortcut for the command from an earlier version of Access, enter the keyboard shortcut
by using the keyboard. The access keys appear. Press the key or keys shown in the keyboard tip associated
with the command that you want. Contextual command tabs In addition to the standard command tabs, Access
also has contextual command tabs. Depending on your context that is, which object you are working with and
what you are doing , one or more contextual command tabs might appear next to the standard command tabs.
Activate a contextual command tab Click the contextual command tab. Press the key or keys shown in the
access key that appears on or closest to the contextual command tab. The contextual command tabs contain
commands and features that you need to work in a specific context. For example, when you open a table in
Design view, the contextual tabs contain commands that apply only when you are working with a table in that
view. As another example, when you open a table in Design view, a contextual command tab named Design
appears next to the Advanced Tools tab. When you click the Design tab, the ribbon shows the commands
available to you only when the object is in Design view. Galleries The ribbon also uses a kind of control called
a gallery. The gallery control is designed to focus your attention on getting the results that you want. Rather
than merely show commands, the gallery control shows the result of using those commands. The idea is to
provide a visual way for you to browse and see what Access can do, with a focus on the results, rather than
focusing solely on the commands themselves. Galleries come in different shapes and sizes. There is a grid
layout, a menu-like representation that drops down, and even an on-ribbon layout that places the content of the
gallery itself on the ribbon. Hiding the ribbon Sometimes, you might need a little more space to devote to your
work area. For that reason, the ribbon can be collapsed so that only the bar with the command tabs remains. To
hide the ribbon, double-click the active command tab. To show it again, double-click the active command tab
again. Hide and restore the ribbon Double-click the active command tab the active tab is the highlighted tab.
Double-click the active command tab again to restore the Ribbon. The default set of commands include Save,
Undo, and Redo, and you can customize the Quick Access Toolbar to include other commands that you use
often. You can also modify the placement of the toolbar and change it from the default small size to large size.
The small toolbar appears next to the command tabs on the ribbon. When you switch to the large size, the
toolbar appears below the ribbon and extends its full width. Customize the Quick Access Toolbar Click the
rightmost drop-down arrow in the toolbar. Under Customize Quick Access Toolbar, click the command that
you want to add, and you are done. Or, if the command is not listed, click More Commands, and proceed to
the next step of this procedure. In the Access Options dialog box, select the command or commands that you
want to add, and then click Add. To remove a command, highlight it in the list on the right, and then click
Remove. Alternatively, double-click the command in the list. Click OK when you are done. Top of Page
Navigation Pane When you open a database or create a new one, the names of your database objects appear in
the Navigation Pane. The database objects include your tables, forms, reports, pages, macros, and modules.
For example, if you want to add a row to a table in Datasheet view, you open that table from the Navigation
Pane. The Navigation Pane is not available in a web browser. To use the Navigation Pane with a web
database, you must first open that database by using Access. To open a database object or apply a command to
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a database object, right-click the object and select a menu item from the context menu. The commands on the
context menu vary according to the object type. Open a database object, such as a table, form, or report In the
Navigation Pane, double-click the object. Note that you can set an option to open objects with a single click in
the Navigation Options dialog box. The Navigation Pane divides your database objects into categories, and
these categories contain groups. Some categories are predefined for you, and you can also create your own
custom groups. By default, the Navigation Pane appears when you open a database, including databases
created in earlier versions of Access. You can prevent the Navigation Pane from appearing by default by
setting a program option. The following set of steps explain how to take each action. The Access Options
dialog box appears. In the left pane, click Current Database. Top of Page Tabbed documents Starting with
Office Access you can display your database objects in tabbed documents instead of overlapping windows.
For everyday interactive use, you may prefer the tabbed document interface. You can enable or disable tabbed
documents by setting your Access Options see Show or hide document tabs , later in this article. However, if
you change the tabbed document settings, you must close and reopen your database for the new settings to
take effect. Show or hide document tabs Click the File tab, and then click Options. Select or clear the Display
Document Tabs check box. Clearing the check box turns off document tabs. The Display Document Tabs
setting is a per-database setting. You must set this independently for each database. After you change the
Display Document Tabs setting, you must close and reopen your database to see the change take effect. New
databases created by using Access or Access display document tabs by default. Databases created by using an
earlier version of Access use overlapping windows by default. Top of Page Status bar As with earlier versions
of Access, in Access , you can display a status bar at the bottom of the window. This standard UI element
continues to be the place to look for status messages, property hints, progress indicators, and so on. With
Access , the status bar also takes on two standard functions that you will also see in the status bar of other
Office programs: You can quickly switch the active window between one of the available views by using the
controls available on the status bar. If you are viewing an object that supports variable zoom, you can adjust
the zoom level to zoom in or out by using the slider on the status bar. The status bar can be enabled or disabled
in the Access Options dialog box. Show or hide the status bar Click the File tab, and then click Options.
Clearing the check box turns off the display of the status bar. Top of Page Mini toolbar In versions of Access
earlier than Access , formatting text often required using a menu or displaying the Formatting toolbar. Using
Access you can format text more easily by using the mini toolbar. When you select text for formatting, the
mini toolbar automatically appears above the selected text. If you move the mouse pointer closer to the mini
toolbar, the mini toolbar fades in and you can use it to apply bold, italic, font size, color, and so on. As you
move the pointer away from the mini toolbar, the mini toolbar fades away. Format text by using the mini
toolbar Select the text to format. The mini toolbar transparently appears above the text. Apply formatting by
using the mini toolbar. Top of Page Getting Help When you have a question, you can get help by pressing F1,
by clicking the question mark icon on the right side of the ribbon. You can also find Help in Backstage view:
Click the File tab, and then click Help. A list of Help resources appears in Backstage view.
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In a resource view, click the Resource tab on the Ribbon and click the Add Resources button in the Insert
group. Select the type of resource you want to add and enter its information. Scope â€” This includes the
quality, functions, and features of your product or service, and the work required to deliver it. Or, click the
Task tab and click the Insert Task button in the Insert group. A new task is inserted above the selected task.
Click the Information button in the Properties group of the Resource tab. Click the Resources tab on the
Ribbon and click the Assign Resources button in the Assignments group. Select the resource s and click
Assign. In a resource view, enter cost amounts in the Std. Rate field, the Ovt. Click the View tab on the
Ribbon and click the Tables button in the Data group. Select Cost from the list. Select the task for which you
want to enter a fixed cost and type the cost in the Fixed Cost field. A blank row is inserted above the selected
task. By default a timeline of the entire project appears above the selected view. To turn this on or off, click
the View tab on the Ribbon and check or uncheck the Timeline check box in the Split View group. Select a
group from the list. Or enter 0 zero in the Duration column. Click the View tab on the Ribbon and click the
Filter list arrow in the Data group. Select a filter from the list. Select a table from the list. Click the Task
Information tab on the Ribbon and click the Information button in the Properties group. Create summary tasks
and subtasks by selecting the task s and clicking the Outdent Task or Indent Task button in the Schedule group
of the Task tab on the Ribbon. Press Ctrl, select the two tasks you want to link in the order they should be
linked, and click the Link Tasks button in the Schedule group of the Task tab on the Ribbon. Press Ctrl and
select the linked tasks in the order they are linked. Click the status bar and select Auto Scheduled or Manually
Scheduled. Click the successor task and click the Information button in the Properties group. Click the task to
which you want to add a deadline and click the Information button in the Properties group. Click the
Advanced tab and enter a deadline into the Deadline box, or choose the constraint you want to use and enter
the Constraint date. Click the column list arrow and select the filter you want to apply to the task list. Click the
View tab on the Ribbon and click the Sort button in the Data group. Select a sorting option from the list.
Select the task you want to update. Select the tasks that you want to mark as on track. Find the resource you
want to update and update new actual work value. Select Variance from the list. Click the Overallocation
check box in the Details group. Or, click the Resource tab on the Ribbon and click the Next Overallocation
button in the Level group. Open Team Planner view. Click and drag a task from an overallocated resource to
another resource.
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Access is a database application design and deployment tool that you can use to keep track of important
information. Many people start using Access when the program that they are using to keep track of something
gradually becomes less fit for the task. For example, suppose you are an event planner, and you want to keep
track of all the details that you need to manage to make your events successful. If you use a word processor or
spreadsheet program to do this, you can easily run into trouble with duplicate and inconsistent data. For
example, an event planning relational database might contain a table with customer information, a table with
vendor information, and a table with event information. The table with event information might have a field to
relate it to the customer table, and a field to relate it to the vendor table. Access is a tool that you can use to
quickly and easily develop relational database applications that help you manage information. You can create
a database to help you keep track of just about any kind of information, such as inventory, professional
contacts, or business processes. In fact, Access comes with templates that you can use right away to track a
variety of information, making things easy even for a beginner. When you open Access When you start Access
, you see the Microsoft Office Backstage view, where you can get information about the current database,
create a new database, open an existing database, and view featured content from Office. Backstage view also
contains many other commands that you can use to adjust, maintain, or share your databases. Commands in
Backstage view generally apply to entire databases, not to objects inside of a database. You can get to
Backstage view at any time by clicking the File tab. Top of Page Find and apply a template Access provides
you with a wide variety of templates that you can use to speed up your database creation process. A template
is a ready-to-use database that contains all of the tables, queries, forms, and reports needed for performing a
specific task. For example, there are templates that can be used to track issues, manage contacts, or keep a
record of expenses. Some templates contain a few sample records to help demonstrate their use. Template
databases can be used as is, or you can customize them to better fit your needs. To find and apply a template to
your database, do the following: On the File tab, click New. Under Available Templates, do one of the
following: To use a template that you already have installed, click My Templates, and then select the template
that you want. To find a template on Office. You can also search for templates on Office. In the Search Office.
Optionally, click the folder icon next to the File Name box to browse to a location where you want to create
the database. Top of Page Create a database from scratch If you want a more thorough introduction to the
concepts behind using Access to create a database, see the article Database design basics. If none of the
templates fits your needs, or if you have data in another program that you want to use in Access, you may
decide that it is better to create a database from scratch. In Access , you have a choice: For more information
about web databases, see the article Build a database to share on the Web. To create a new database, do the
following: The choice that you make here will determine what features are available in the database. Desktop
databases cannot be published to the Web, and web databases do not support some desktop features, such as
totals queries. On the right, type a name for your database in the File Name box. To change the location in
which you create the file, click Browse next to the File Name box, browse to and select the new location, and
then click OK. Access creates the database, and then opens an empty table named Table1 in Datasheet view.
Access puts the cursor in the first empty cell in the Click to Add column of the new table. Entering data in
Datasheet view is designed to be very similar to entering data in an Excel worksheet. The main restriction is
that data must be entered in contiguous rows and columns, starting at the upper-left corner of the datasheet.
You should not try to format your data by including blank rows or columns as you might do in an Excel
worksheet, because doing so will waste space in your table. The table merely contains your data. All visual
presentation of that data will be done in the forms and reports that you design later. The table structure is
created while you enter data. Any time that you add a new column to the datasheet, a new field is defined in
the table. Access sets the data type of the field based on the type of data that you enter. If you later attempt to
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enter a non-date value such as a name or a phone number in that field, Access displays a message informing
you that the value does not match the data type of the column. When possible, you should plan your table so
that each column contains the same type of data, whether it is text, dates, numbers, or some other type. This
makes it much easier to build queries, forms, and reports that select just the data that you want. If you do not
want to enter data yet, click Close. Top of Page Open an existing Access database Tip: To quickly open one of
the last several databases that you had open, on the File tab, click Recent, and then click the file name. On the
File tab, click Open. In the folder list, double-click folders until you open the folder that contains the database.
When you find the database, do one of the following: To open the database in default open mode, double-click
it. To open the database for shared access in a multiuser environment, so that both you and other users can
both read and write to the database at the same time, click Open. To open the database for read-only access, so
that you can view it but cannot edit it, click the arrow next to the Open button, and then click Open
Read-Only. To open the database for exclusive access, so that no one else can open it while you have it open,
click the arrow next to the Open button, and then click Open Exclusive. To open the database for read-only
access, click the arrow next to the Open button, and then click Open Exclusive Read-Only Other users can still
open the database, but they only have read-only access. In the list of drives, right-click the drive that you think
might contain the database, and then click Search. If the database is found, open it by double-clicking it in the
Search Results dialog box. Because the search was initiated from the Open dialog box, you must click Cancel
in that dialog box before the database will open. Access automatically creates a new Access database in the
same folder as the data file, and adds links to each table in the external database. Top of Page Get started using
your new database Depending on the template that you used, you might need to do one or more of the
following to get started with the new database: If Access displays a Login dialog box with an empty list of
users, use the following procedure to get started: Fill in the User Details form. Select the user name you just
entered, and then click Login. If Access displays an empty datasheet, you can begin typing data directly into
that datasheet, or click other buttons and tabs to explore the database. If Access displays a Getting Started
page, you can click links on that page to learn more about the database, or click other buttons and tabs to
explore the database. If Access displays a Security Warning message in the message bar, and you trust the
source of the template, click Enable Content. If the database requires a login, you will need to log in again. For
desktop and web databases, you also want to begin with one of these steps:
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Click Open and in wizard window hit Next to continue. In this step, click Browse to select the main database
file, i. Now from Root install folder, select a path of folder to install the setup file and from Install subfolder,
enter name of folder you want installer to create. Beneath it, you can see the full folder path. Under
Pre-installation requirements, choose an option among three available options; a installer will be requiring
Access installed on the system, b in-case of Access absence, it will require Access runtime to run the installer,
and finally c if system has neither access nor Access runtime, then the runtime will be bundled with the
installer for including Access runtime, you need to specify the location where it is residing. Under Shortcut
Options, enable Desktop option, to create a shortcut of main database file on desktop and enter the shortcut
name. Once done configuring all the necessary options, click Next to proceed further. In this step, we will be
adding all the files to be bundled in MSI installer, click Add and select the application relevant database files.
It will instantly add the files, for removing any database file s , select the file and click Remove. If you need to
add registry keys with app to operate according to requirements, click Add, to add registry keys. Once done,
click Next. The last step is about adding installer properties and other feature information. Only input panes
marked with red asterisk are mandatory. Click OK to end the wizard. It will instantly open the folder where
the it has created an MSI installer it contains all the selected database files. To test it out, run the installer. You
will see the installer title as specified in wizard. Click Next to proceed with the installer steps. It will start
installing bundled database as an app at the specified location as specified in wizard. Once installed, move to
UserApp folder to view the extracted database files.
Chapter 6 : Access Creating Forms
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